Experiencing Delays on Dialer Sessions

Incident Report for Close

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 04:50 PDT

Monitoring

A fix has been implemented, and we are currently monitoring this.

New updates to follow.
Posted Oct 22, 2025 - 04:10 PDT

Investigating

We are currently investigating problems with Lead Pages being loaded too slowly while on a Dialer session.
Posted Oct 22, 2025 - 03:35 PDT
This incident affected: Phone (Dialer).