Database issues

Incident Report for Close

Postmortem

Summary

Close sincerely apologizes for the interruption of our service. We take the stability of our platform very seriously. Below is an explanation of what happened and how we will prevent another such interruption from occurring.

The Close App and API were severely disrupted for all users for 18 minutes between 15:57 and 16:15 UTC on Monday March 16, 2026. Automated systems restored functionality by 16:15 UTC.

Incident Timeline

Time (UTC) Event
2026-03-16
15:57:00 Automated Database Maintenance begins
15:58:42 Incident detected by monitoring
15:58:49 Escalation acknowledged by Close Engineering On-Call
16:02:41 Incident accepted by Close Engineering
16:15:00 Affected database restored to normal operation
17:09:22 Incident resolved

Root Cause and Resolution

At ~15:57 UTC an automated database maintenance process began that starved our production database cluster of resources. This caused our primary instance and both replica instances of the production cluster to become unavailable for ~18 minutes. The system recovered and began performing normally at 16:15 UTC.

To prevent this from happening in the future Close Engineering has provisioned additional resources to the affected database cluster to make it more resilient to sudden demand spikes. Close Engineering will also perform an audit of the maintenance process' configuration to identify opportunities to reduce its impact on system performance.

Posted Mar 19, 2026 - 08:13 PDT

Resolved

This incident is resolved. Close has returned to normal performance.
Posted Mar 16, 2026 - 09:55 PDT

Update

Close services continue to recover. Most customers should see normal performance. Close Engineering continues to monitor the recovery.
Posted Mar 16, 2026 - 09:45 PDT

Monitoring

Database infrastructure is operational.
Posted Mar 16, 2026 - 09:27 PDT

Update

We are investigating the issue and seeing some recovery.
Posted Mar 16, 2026 - 09:16 PDT

Investigating

We are currently investigating this issue.
Posted Mar 16, 2026 - 09:08 PDT
This incident affected: Application UI and API.