Call Recordings Processing Delayed

Incident Report for Close

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 14:18 PDT

Update

We're continuing to monitor the situation and expect gradual recovery over the next hour.
Posted Apr 23, 2026 - 12:45 PDT

Update

We're continuing to monitor the situation and expect gradual recovery over the next hour.
Posted Apr 23, 2026 - 11:52 PDT

Monitoring

We are experiencing an issue with a 3rd party provider.
Posted Apr 23, 2026 - 10:32 PDT

Update

We are experiencing an issue with a 3rd party provider.
Posted Apr 23, 2026 - 09:56 PDT

Investigating

We are currently investigating this issue.
Posted Apr 23, 2026 - 09:16 PDT
This incident affected: Phone (Call Recording).