Calling Service Disconnections

Incident Report for Close

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 06:08 PDT

Monitoring

Our telephony provider, Twilio, has fixed the accounts affected so far and is actively working on preventing the problem from reoccurring.
Posted Aug 06, 2025 - 03:55 PDT

Identified

We've identified a problem with our telephony provider, Twilio, which incorrectly flags some (not all) accounts as compromised and thus disables their ability to make calls. We have escalated the problem and are working urgently with Twilio to resolve the issue.
Posted Aug 06, 2025 - 01:16 PDT
This incident affected: Phone (Phone Service, Incoming Calls, Outgoing Calls, Dialer, Call Recording, Telephony Provider Connectivity).