Service Interruption

Incident Report for Close

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 06:12 PDT

Update

AWS has reported partial recovery on this incident (https://health.aws.amazon.com/health/status), but services have yet to recover fully.

Our service provider, Twilio, is also actively monitoring this (https://status.twilio.com/)

We will continue to keep you posted.
Posted Oct 20, 2025 - 04:16 PDT

Monitoring

There’s currently an outage on AWS’s end in the us-east-1 region. While our hosting is mainly in another region, many other services, including calling, are affected.

We are actively monitoring this, and we will keep you updated
Posted Oct 20, 2025 - 03:38 PDT
This incident affected: Phone (Phone Service, Outgoing Calls, Telephony Provider Connectivity).