Background Processing Delayed
Incident Report for Close
Postmortem

Close sincerely apologizes for the interruption of our service. We take the stability of our platform very seriously. Below is an explanation of what happened and how we will prevent another such interruption from occurring. 

Impact

Our processing of background tasks was delayed between 13:30 and 15:30 UTC on September 15, 2023. Some customers may have noticed the Close Application taking longer than normal to sync data from third parties like Zoom or Calendly. Inbox notifications may have been delayed. Some Power Dialer sessions may also have been impacted. No data was lost during this incident.

Root Cause and Resolution

At 13:25 UTC on September 15, 2023 a new version of the Close Application was deployed to production. This change introduced a bug into our background task processing system that prevented it from processing new work. By 14:35 Close Engineering deployed a a fix and performance began to recover. The Close Application completely recovered by 15:30 UTC.

To prevent similar issues from happening in the future, Close Engineering will upgrade our background task processing system to better isolate workloads that could potentially break. 

Timeline

  • 13:25 UTC - A new version of the Close app is published.
  • 13:39 UTC - Close Engineering becomes aware of a problem with background task processing and takes steps to remediate.
  • 14:35 UTC - Close Engineering deploys a fixed version of the Close application. Performance begins to recover.
  • 15:30 UTC - The Close Application is fully recovered and performing normally.
Posted Sep 15, 2023 - 13:47 PDT

Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 08:31 PDT
Update
A fix has been implemented. The Close application and API are fully functional. We expect full recovery of background task processing performance in the next 15 minutes.
Posted Sep 15, 2023 - 08:05 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2023 - 07:41 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 15, 2023 - 07:41 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2023 - 07:37 PDT
Investigating
We are currently investigating this issue.
Posted Sep 15, 2023 - 07:37 PDT
This incident affected: Application UI and API.