Delayed processing of Workflow Triggers

Incident Report for Close

Resolved

Unplanned patches have been applies and our system has processed through the delayed events.
Posted Sep 05, 2025 - 04:13 PDT

Identified

We have identified the problem as coming from our compute provider, AWS. An unplanned patch to our Event Stream is currently underway.
Posted Sep 05, 2025 - 04:01 PDT

Investigating

We are currently investigating a delay in processing triggers that kick off Workflow actions.
Posted Sep 05, 2025 - 03:45 PDT