Search delays
Incident Report for Close
Resolved
We've identified and resolved the issue. Sorry for the slow down!
Posted Jul 24, 2014 - 08:39 PDT
Investigating
We're investigating a slowdown in our search system that is causing updates/additions/deletes to be slow to appear within the application.
Posted Jul 24, 2014 - 08:31 PDT