Service interruption

Incident Report for Close

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:27 PDT

Investigating

There’s currently an outage on AWS’s end in a certain region. While our hosting is mainly in another region, many other services, including calling, are affected.
Posted Oct 20, 2025 - 07:20 PDT
This incident affected: Phone (Phone Service, Outgoing Calls).