Calling outage
Incident Report for Close
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 11:33 PDT
Monitoring
A fix has been implemented by Twilio and baseline call functionality has been restored.
Posted Apr 22, 2024 - 10:36 PDT
Investigating
Our telephony provider, Twilio, is currently experiencing issues on their side that are impacting Close users.

We will update this page as soon as we have more information from Twilio.
Posted Apr 22, 2024 - 07:53 PDT
This incident affected: Phone (Phone Service).